您的需求已经提交,我们将在48小时内联系您
全国服务热线:400-1000-221
确定
免费享受企业级云安全服务
获取手机验证码
{{message}}
免费试用
Linux内核多个安全漏洞风险通告
作者:
发布时间:2021-03-16

  漏洞详情

  近日,国外研究团队披露多个Linux内核安全漏洞,漏洞编号:CVE-2021-27363,CVE-2021-27364,CVE-2021-27365,普通用户可以通过利用此漏洞,在已加载scsi_transport_iscsi内核模块的Linux发行版主机上获取root权限。

  iSCSI使用 TCP/IP 协议(一般使用TCP端口860和3260)。在两部计算机之间利用iSCSI的协议来交换SCSI命令,让计算机可以通过高速的局域网集线来把SAN模拟成为本地的储存设备。

  CVE-2021-27363 内核指针泄露(信息泄露):

  内核指针泄漏可以用来确定iscsi_transport结构的地址。当一个iSCSI传输在iSCSI子系统中注册时,传输的句柄可以通过sysfs文件系统在/sys/class/iscsi_transport/$TRANSPORT_NAME/handle处被非root用户获取。当读取时,show_transport_handle函数(在drivers/scsi/scsi_transport_iscsi.c中)会被调用,从而可泄露该句柄。

  CVE-2021-27364 越界读取(信息泄露,拒绝服务):

  由于drivers/scsi/scsi_transport_iscsi.c 受到非root用户发送的恶意 Netlink 消息的影响,导致iSCSI中存在越界读取漏洞。

  CVE-2021-27365 堆缓冲区溢出(本地权限提升、信息泄露、拒绝服务):

  由于某些iSCSI数据结构没有适当的长度限制或检查,并可能超过PAGE_SIZE值。非root用户的攻击者可以发送与iSCSI关联的Netlink消息,并使其长度为Netlink消息的最大长度,最终可导致在目标系统上提升权限等危害。

  风险等级

  高

  漏洞风险

  攻击者可利用该漏洞造成提升权限,拒绝服务等危害,漏洞细节已公开

  影响版本

  Linux 内核版本 < 5.11.4;

  Linux 内核版本 < 5.10.21;

  Linux 内核版本 < 5.4.103;

  Linux 内核版本 < 4.19.179;

  Linux 内核版本 < 4.14.224;

  Linux 内核版本 < 4.9.260;

  Linux 内核版本 < 4.4.260

  及其他所有加载scsi_transport_iscsi内核模块的Linux发行版

  安全版本

  Linux 内核版本 >= 5.11.4;

  Linux 内核版本 >= 5.10.21;

  Linux 内核版本 >= 5.4.103;

  Linux 内核版本 >= 4.19.179;

  Linux 内核版本 >= 4.14.224;

  Linux 内核版本 >= 4.9.260;

  Linux 内核版本 >= 4.4.260

  修复建议

  目前上述Linux内核安全版本已修复相关漏洞,请检查所使用的Linux内核版本,并酌情及时升级至安全版本。(对于 3.x 和 2.6.23 等不再受支持的 EOL 内核版本,将不会发布针对上述漏洞的补丁)

  官方网站:https://www.kernel.org/

  【备注】:建议您在升级前做好数据备份工作,测试并评估业务运行状况,避免出现意外

  漏洞参考

  https://nvd.nist.gov/vuln/detail/CVE-2021-27363

  https://nvd.nist.gov/vuln/detail/CVE-2021-27364

  https://nvd.nist.gov/vuln/detail/CVE-2021-27365

  https://blog.grimm-co.com/2021/03/new-old-bugs-in-linux-kernel.html